FAQ : Compatibilité des versions

Discutions générales sur le DSPiy et tout ce qui s'y rattache
Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 3226
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

FAQ : Compatibilité des versions

Messagepar thierryvalk » mar. 4 août 2015 20:05

DStudio ainsi que le firmware évoluent de temps à autre.

Que ce soit DSPiyV1 ou V2, les dernières versions sont en théorie les plus pertinentes.
D’un autre côté, celui qui a un DSPiy avec son appli dedans et que tout est bon n’a pas toujours grand intérêt à se mettre à niveau s’il ne désire pas les nouvelles fonctionnalités.
On a deux versions : V3 et V4 pour fimware et DStudio.
Si le firmware est en V4 il faudra DStudio V4 et inversement et de même pour V3.

Pour les applis, une Appli V4 ne fonctionnera pas avec DStudio V3.
Par contre une Appli V3 ouverte dans DStudio V4 sera automatiquement convertie en V4 et donc ne sera plus compatible avec DStudio V3.
A noter que pour les DSPiy V2 il faut obligatoirement DStudio et Firmware en V4.
Et pour un DSPiy V1 + carte ADAU1452 DStudio V4R05 minimum.

Voilà pour la théorie. :)

Avatar de l’utilisateur
philby
Messages : 325
Enregistré le : ven. 10 juil. 2015 12:28
Localisation : Gironde France
Contact :

Re: FAQ : Compatibilité des versions

Messagepar philby » mer. 5 août 2015 09:13

Merci Thierry pour ces infos bien précieuses...
Je rajoute juste un lien très utile :

http://www.dspiy.be/download.html

Pour info, je tourne sur des applis V3 (donc converties V4), sur un DSPIY V1, firmware V4_10 et Dstudio V4.05.

blazing
Messages : 43
Enregistré le : jeu. 16 juil. 2015 16:48
Localisation : orsay

Re: FAQ : Compatibilité des versions

Messagepar blazing » jeu. 10 déc. 2015 10:09

J'ai installé DSpiy_studio V4.05, avec mon DSPiy V j'ai pas de problème de communication USB.
En revanche avec mon DSpiy V1 ( CG1) avec son firmware d'origine, je perd la communication (error com TX HIB) dés que je transfert dans la ram et donc impossibilité de mettre en preset, je me suis dit que ça venait du firmware, j'ai tenté un flashage avec flashmagic, mais quand je fai la manip sur BP5+mise sous tension, l'écran oled reste éteint.
Faudrait que je test avec mes autre DSPiy V1.
Faut il que j’installe une ancienne version de DStudio (sans l'onglet avancé "mise à jour firmware propre au DSPiy V2) ?

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 3226
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: FAQ : Compatibilité des versions

Messagepar thierryvalk » jeu. 10 déc. 2015 10:23

Je présume que ton message d’erreur est Error com TX HID ?
C’est pas logique car un message avec HID c’est uniquement pour les V2.
Tu as bien débranché ton DSPiy V2 ?
As-tu bien l’info comme quoi ton DSPiy est connecté ?
Edit : je pense qu'il faut d'abord faire la mise à jour du firmware.

Faut il que j’installe une ancienne version de DStudio (sans l'onglet avancé "mise à jour firmware propre au DSPiy V2) ?

Non, il n’y a pas de différence entre V1 et V2 tant au niveau des firmware que de DStudio.
Par contre si ton firmware de V1 est très ancien il faut le mettre à jour avant toutes autres choses.

Pour cela, tu branche ton DSPiy V1 en USB (avec un câble pas trop long car les V1 sont plus susceptibles que les V2) et sous tension.
Windows doit faire ding ding pour dire qu’il a un USB de reconnu.
Tu lance DStudio.
Tu te moque des messages d’erreur.
Tu vas dans l’onglet de mise à jour et fait la manip, c’est normal que le OLED reste éteint vu que c’est le bootloader qui a pris la main.
Tu dois au final avoir le message de mise à jour réussie, si pas tu recommence sans quitter DStudio.
Tu coupes tout, DSPiy et DStudio .

blazing
Messages : 43
Enregistré le : jeu. 16 juil. 2015 16:48
Localisation : orsay

Re: FAQ : Compatibilité des versions

Messagepar blazing » jeu. 10 déc. 2015 13:01

Je parle bien du DSPiy V1 (CG1), je dois me tromper pour HID (c'est pour le V2), mais j'ai bien systématiquement une perte de connexion après un transfer vers ram du le DSPiy v1.
J'ai vu que philby utilisais un firmware en .bin alors que flashmagic ne prend que des .hex.
Je ne pense pas qu'on puisse flasher le firmware à partir de DStudio pour un dspiy V1(comme on peut le faire avec le dspiy V2).
Je n'ai pas emporté le dspiy V1 au boulot, je ne peut pas tester tout de suite.

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 3226
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: FAQ : Compatibilité des versions

Messagepar thierryvalk » jeu. 10 déc. 2015 13:05

Sisi, on peut flasher un V1 tout comme on le fait pour un V2 avec DStudio; il faut oublier flashmagic, les firmwares ne sont plus qu'en .bin

Et forcément un DSPiy de la CG1 n'a pas le bon firmware.

blazing
Messages : 43
Enregistré le : jeu. 16 juil. 2015 16:48
Localisation : orsay

Re: FAQ : Compatibilité des versions

Messagepar blazing » jeu. 10 déc. 2015 13:44

Ha OK, merci, par contre il faut malgré tout, pour le dspiy V1, installer le driver usb (pour simuler le port com), et ensuite je flash à partir de la dernière version de DSstudio et les firmware en .bin, on oubli les .hex.
ps : désolé si je pause des questions qui ont du déjà trouver des réponses sur le forum HCFR, je n'ai pas peu suivre l'intégralité des sujets concernant le DSPiy, presque trop prolifique, c'est magnifique quand même :super: .

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 3226
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: FAQ : Compatibilité des versions

Messagepar thierryvalk » jeu. 10 déc. 2015 14:25

Aucun souci, oui certaines questions ont été posées, mais pratiquement sur un seul sujet qui devenait très lourd à suivre.

En effet pour le V1 et contrairement au V2 il faut installer le driver de FDTI pour le port com virtuel.

Avatar de l’utilisateur
alka
Administrateur du site
Messages : 2608
Enregistré le : mer. 15 juil. 2015 15:18
Localisation : 92
Contact :

Re: FAQ : Compatibilité des versions

Messagepar alka » jeu. 10 déc. 2015 17:19

blazing a écrit :Je parle bien du DSPiy V1 (CG1), je dois me tromper pour HID (c'est pour le V2), mais j'ai bien systématiquement une perte de connexion après un transfer vers ram du le DSPiy v1.

le DSPiy v1 de CG1 était assez sensible a la qualité et a la longueur du cable USB utilisé. Si vraiment c'est problématique, faudrait essayer avec un cable plus court, dans beaucoup de cas (y compris chez moi) ça a résolu la question.
acheter un DSPiy ? c'est ici

Avatar de l’utilisateur
manudrz
Messages : 630
Enregistré le : dim. 25 oct. 2015 17:41
Localisation : 35300 Fougères

Re: FAQ : Compatibilité des versions

Messagepar manudrz » jeu. 10 déc. 2015 22:41

T'inquiète pas blazing avec tes questions, moi je ne fais que ça :hehe: J'ai commencé à lire le topic principal du DSPiy, 33 pages sur 300 et quelques, je comprends presque rien (tazz28 pffff=chinois), mais je me dis que ça ne peut qu'être instructif...
Et puis les gens ici sont vachement patients et didactiques !

Avatar de l’utilisateur
alka
Administrateur du site
Messages : 2608
Enregistré le : mer. 15 juil. 2015 15:18
Localisation : 92
Contact :

Re: FAQ : Compatibilité des versions

Messagepar alka » jeu. 10 déc. 2015 22:55

manudrz a écrit :J'ai commencé à lire le topic principal du DSPiy, 33 pages sur 300 et quelques....

il n'y a que 10% d'utile dans ce sujet, t'as déjà dépassé :mrgreen:

un forum ca part souvent dans tous les sens et ce sujet ne déroge pas! En plus, plein de choses obsolètes ou maintenant fausses a ne pas se rappeler (flashmagic par exemple)
Je pense qu'on peut sans regret ne pas lire ce sujet si on démarre aujourd'hui. C'est utile si on veut connaitre la génèse du projet.

En tant qu'utilisateur, vaut mieux lire tout ce qui est sur le site dsipy.be ( et si on a un dspiy v1, lire le site de la v1)
acheter un DSPiy ? c'est ici

Avatar de l’utilisateur
manudrz
Messages : 630
Enregistré le : dim. 25 oct. 2015 17:41
Localisation : 35300 Fougères

Re: FAQ : Compatibilité des versions

Messagepar manudrz » ven. 11 déc. 2015 08:04

Oui je sais bien mais c'est + pour ma curiosité personnelle. Je crois que j'aurais du mal à aller au bout c'est clair ;)
Il est d'ailleurs évoqué à un moment la possibilité d'une carte DAC amovible et upgradable à base d'AKM... "Il est + que borné lui" ::d

blazing
Messages : 43
Enregistré le : jeu. 16 juil. 2015 16:48
Localisation : orsay

Re: FAQ : Compatibilité des versions

Messagepar blazing » ven. 11 déc. 2015 10:30

Merci pour les conseils, ça fonctionne bien après la mise à jour à partir de DS_studio avec le firmware 4_10.bin, cool ça me simplifie la vie.
J’avais entrepris de remplacer les résistances R49 et R50 par des 33ohms) du port USB pour améliorer la stabilité de la connexion, et en fait les carte avait déjà été équipé de 33 ohms, bref ça m'a permit de m'essayer au dé-soudage soudage CMS, c'est faisable. j'utilise un câble de moins d' 1m, j'ai malgrés tout perdu la connexion 1 fois avec le nouveau firmware, je vais voire à la longue.
Faut il désactiver le driver USB (port com virtuel) momentanément pour effectuer un réglage éventuel avec un DSPiy V2 ?

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 3226
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: FAQ : Compatibilité des versions

Messagepar thierryvalk » ven. 11 déc. 2015 10:39

Super. :super:
Faut il désactiver le driver USB (port com virtuel) momentanément pour effectuer un réglage éventuel avec un DSPiy V2 ?

Non, tu débranche ton V1, et branche simplement le V2.
Tout est automatique et ne devrait en théorie ne poser aucun problème.
Dans quelque temps tu auras même oublié que tu as 2 versions différentes de DSPiy.

blazing
Messages : 43
Enregistré le : jeu. 16 juil. 2015 16:48
Localisation : orsay

Re: FAQ : Compatibilité des versions

Messagepar blazing » ven. 11 déc. 2015 12:12

C'est vraiment ROYAL, MERCI.


Retourner vers « DSPiy général »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 10 invités