global10k2x3 instabilité

Discutions générales sur le DSPiy et tout ce qui s'y rattache
pacapona
Messages : 11
Enregistré le : jeu. 10 nov. 2016 18:10

global10k2x3 instabilité

Messagepar pacapona » jeu. 10 nov. 2016 21:25

Hello,

D'abord un grand merci a tout les contributeurs du DSPiy.

Je viens de finir mes nouvelles enceintes (sujet en pause dans HCFR)
Du coup j'ai mis a jour mon DSPIY V2 avec le dernier firmware, installé dstudio v5.
D'habitude j'arrive a me débrouiller seul mais depuis ces mises à jour j'ai quelques soucis.

Y a quelques bug y m'semble... pt'être que c'est moi aussi...

Ma carte son pour les mesures est une USBdualPre project serie avec un micro emm-6.
Le firmware est en 4.21
J'utilise DStudio v5
l'appli est global10k2x3

Mes débuts après mise à jour;
Pour l'instant je n'ai que 2 preset;
1) entrée analog (cdualpre pour réglage des enceintes)
2) entrée toslink1 (raspberry avec digi+ à l'autre bout)

Mes soucis;

1) 2x me suis retrouvé avec l'erreur "erreur i2c"
Après suppression des presets/redémarage/remise en place des preset c'est ok... Mais il a fallu un redémarage supplémentaire pour que le son sorte...

2) Avec l'entrée toslink j'ai une perte régulière du son, 1-2 secondes de coupures régulières. Jamais eu ce problème avant ces derniers changements

Une autre personnes avec ces problèmes?
Une idées?

Je continue a aprivoiser dstudio v5 en attendant...
Merci!

Avatar de l’utilisateur
alka
Administrateur du site
Messages : 2190
Enregistré le : mer. 15 juil. 2015 15:18
Localisation : 92
Contact :

Re: global10k2x3 instabilité

Messagepar alka » jeu. 10 nov. 2016 21:42

salut,
ca faisait longtemps
pour le 1/ t'as fait ce qu'il fallait : effacer les presets , refaire les applis et remettre en preset permet d'éviter les soucis. T'as bien utilisé la dernière version de l'appli global10k2x3 pour tes nouveaux presets ?
pour 2/ ca ressemble a une perte de synchro du spdif et la durée de coupurer de 1 à 2 secondes c'est long. Bizarre. Tu peux vérifier avec une autre source toslink ?

ps: si tes deux presets sont identiques a part la source, il est possible maintenant de n'avoir qu'un seul preset et de naviguer entre les sources. Ca évite pas mal de copier/coller.
acheter un DSPiy ? c'est ici

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 2793
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: global10k2x3 instabilité

Messagepar thierryvalk » jeu. 10 nov. 2016 21:46

Pour le premier soucis : erreur I2C qui veut dire que le DSP ne communique plus, tu n'es pas le premier.
Par contre, j'avoue ne pas en connaître l'origine.
Changement d'une appli avec des restes de l'ancienne? Idem mais dans la gestion de la flash ou problème lors d'un transfert ?

J'ai malheureusement trop peu d'éléments pour faire des recherches sérieuses.

Pour le problème de toslink, faudrait tout bêtement vérifier ta fiche et connecteur, c'est pas super terrible (mais là c'est pas ma faute :mrgreen: ) comme système.

Je vérifierait aussi l'alimentation 5V si cela n'a pas déjà été fait, pourrait éventuellement être la cause des 2 soucis.

Niveau softs, normalement pas de changement à ces niveaux.

pacapona
Messages : 11
Enregistré le : jeu. 10 nov. 2016 18:10

Re: global10k2x3 instabilité

Messagepar pacapona » jeu. 10 nov. 2016 23:02

Oui longtemps... Mais je reviens avec de nouvelles enceintes... J'ai appris ce qu'était une défonceuse :-) Pour faire autre chose que des carrés et rectangles empilés :-) Mais c'est un autre sujet...

Merci pour votre présence! :merci:

Pour l'erreur i2c elle ne c'est pas reproduite. Par contre pour activer une autre entrée;

- Pas moyen de sélectionner les sources dispos sur un preset. Les carrés blanc ne sont pas cochable et je peux pas scroller dans la liste...
- Donc j'ai fait un nouveau preset, du coup perte du son sur tous les preset... reboot et c'est ok, le son est là et effectivement plus de perte de signale...

Au passage j'ai remarqué que j'avais pas de analog2 possible en entrée... normale?

Une ptite lanterne pour m'éclairer?

Avatar de l’utilisateur
alka
Administrateur du site
Messages : 2190
Enregistré le : mer. 15 juil. 2015 15:18
Localisation : 92
Contact :

Re: global10k2x3 instabilité

Messagepar alka » jeu. 10 nov. 2016 23:20

Si les cases ne sont pas cochables, t'es sur une ancienne version d'appli. Ca explique des choses.

il y a moyen de récupérer les infos manquantes par des imports mais c'est un risque d'erreur supplémentaire.
Vu le peu de temps que ça prend, je ferai un reset avec tout a neuf.
1) copies d'écran de confg, filtres et xover de l'appli actuelle pour ne rien oublier
2) purger les presets actuels dans le dspiy
3) télécharger la dernière version de l'appli depuis le forum
4) ouvrir l'appli téléchargée dans DS5 et la paramétrer (les copies d'écran pour recopier tous les réglages).
5) Sauvergarder et mise en preset de la nouvelle.

Ca devrait résoudre pas mal de tes soucis.
acheter un DSPiy ? c'est ici

pacapona
Messages : 11
Enregistré le : jeu. 10 nov. 2016 18:10

Re: global10k2x3 instabilité

Messagepar pacapona » ven. 11 nov. 2016 00:48

J'ai nettoyer tout les mémoires du dspiy et essayé 3 applis;
et c'est dans uniquement dans global10k2x3 que j'ai le soucis des sources... avec la dernière applis bien sur...
http://www.dspiy.be/forum/viewtopic.php?f=9&t=50

T'arrive juste a me pointer l'endroit sur le forum ou y a les infos sur le contenu a ajouter dans le fichier app.
J'étais tombé dessus y a quelques temps mais je remet pas la main dessus...
Mais tranquil je vais trouver demain sinon...

Mon sujet et mal nommer...

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 2793
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: global10k2x3 instabilité

Messagepar thierryvalk » ven. 11 nov. 2016 07:18

Ceci ?
viewtopic.php?f=2&t=77

PS : dans "annonces" il y a un sujet Index et liens.
Il ne faut pas hésiter a le consulter. ( et pour moi et Alain de le mettre à jour )
Une belle doc complète avec des chapitres serait idéale, mais c'est lourd a faire et surtout maintenir à jour.

Si je comprend bien, l'erreur I2C est intervenue après des mises à jour. Sans doute un automatisme qui fonctionne mal, pas trop grave si on le sait et surtout si l'on connaît la solution pour débloquer le système.

Je vais vérifier cette appli, mais il faudra sans doute patienter quelques jours.

Merci pour ces retours qui permettent d'y voir plus clair et aide les suivants.

Avatar de l’utilisateur
alka
Administrateur du site
Messages : 2190
Enregistré le : mer. 15 juil. 2015 15:18
Localisation : 92
Contact :

Re: global10k2x3 instabilité

Messagepar alka » ven. 11 nov. 2016 11:43

Effectivement, en y regardant de plus près, la version téléchargeable de l'appli global10K2x3 n'a pas les mises a jour. étrange. Ca semble ne pas etre non plus le cas pour fir7k3k ni fir6k3k8. Les applis IIR sont mises a jour v4. Les FIR seraient passées a travers ?
La mise a jour manuelle s'impose.

C'est cette phrase qui me donne de l'espoir que ce n'est pas un souci hardware
Donc j'ai fait un nouveau preset, du coup perte du son sur tous les preset... reboot et c'est ok, le son est là et effectivement plus de perte de signal...


je sais pas quel type d'appli a été utilisée pour faire ce nouveau preset.
acheter un DSPiy ? c'est ici

pacapona
Messages : 11
Enregistré le : jeu. 10 nov. 2016 18:10

Re: global10k2x3 instabilité

Messagepar pacapona » ven. 11 nov. 2016 13:47

Pour l'instant j'utilise uniquement global10k2x3.
J'ai ajouté ce qu'il fallait comme indiqué dans le lien ci-dessus (merci!). Du coup c'est bon je peux sélectionner les sources voulues
J'ai refait tout mes branchements et grossièrement isolé les électroniques des vibrations et du coup je n'ai plus de perte de synchronicité non plus entre les sources et le DSPiy :) (du moins pour l'instant)

Merci!

pacapona
Messages : 11
Enregistré le : jeu. 10 nov. 2016 18:10

Re: global10k2x3 instabilité

Messagepar pacapona » sam. 12 nov. 2016 15:42

Encore un petit soucis...
J'ai créé une preset avec un un import de rephase afin de donner une courbe différent. (pas de linéarisation de phase... j'y comprend rien :gene: )

Lors du passage d'un preset à l'autre mon dspiy a bloqué et sorti des son pas cool du tout dans mes hp...
Reboot mais plus de son...

Nettoyage des presets/reboot/rechargement des presets/reboot --> plantage lors du changement de preset.

Du coup rebelotte nettoyage mais cette fois que le preset avec import du travail de rephase. ok j'ai du son.
J'ai ajouter le preset sans rephase en 2 + reboot, cette fois je peux switcher de l'un a l'autre sans soucis... pas compris...

Par contre pouvoir faire ces courbes comme en veut via rephase c'est vraiment nickel, la moindre différence de courbe change immédiatement le rendu.
Le fait de pouvoir changer ces sources sans changer de presets c'est top!

J'apprécie ce DSPiy malgré mes différents ptit soucis!

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 2793
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: global10k2x3 instabilité

Messagepar thierryvalk » lun. 14 nov. 2016 16:53

Si je comprend bien (mais pas certain du tout) tu utiliserais au moins 2 presets dont l'un est une appli Global FIR et l'autre en IIR ?

Si tu as ces preset et +- l'ordre dans lequel tu les avait chargés, m'intéresse.
Je pourrais peut-être le reproduire chez moi.

pacapona
Messages : 11
Enregistré le : jeu. 10 nov. 2016 18:10

Re: global10k2x3 instabilité

Messagepar pacapona » lun. 14 nov. 2016 22:18

Je n'utilise que l'appli global FIIR mais dans un des presets je n'avais pas chargé d'export de rephase quand a l'ordre j'en ai essayé pas mal jusqu'a ce que ça passe...

Par contre la j'ai trouvé un autre problème qui a près + de 2 heures de mises au point m'embête...
Je pense qu'il doit rester des traces d'un vieux export de rephase dans l'appli que j'ai téléchargé sur le forum car;

Je me suis fait une courbe bien correcte (trop droite), en ajoutant une modif dans "Global_EQ" le résultat est déprimant;
la modif en image; (en toute logique résultat nul)
Image

Ben non... voici le résultat (la courbe plate c'est avant la modif...)
Image

Bon du coup j'ai créer un export de rephase sans correction et je recommence en espérant retrouver ma courbe plate...

Mais je veux bien qu'on m'explique un peu car j'ai peur que ça me joue encore des tours...

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 2793
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: global10k2x3 instabilité

Messagepar thierryvalk » lun. 14 nov. 2016 22:44

Avec cette ampli tu as 2 types de corrections.
En FIR via rephase et en IIR, corrections totalement indépendantes vues que sur des DSP différents.
Je ne comprend pas trop en IIR ton EQ à 1000Hz avec un Boost à 0, pas très logique car ne fait rien.
Et pour le FIR, il faut dans tous les cas y importer une impulse.

pacapona
Messages : 11
Enregistré le : jeu. 10 nov. 2016 18:10

Re: global10k2x3 instabilité

Messagepar pacapona » mar. 15 nov. 2016 02:40

Pour l'ordre des presets, que avec l'appli globale toujours.

D'abors sans fichier créé par rephase et en 2 applis avec fichier créer via rephase.

Je n'ai plus se problème depuis mais DSPiy plante de temps en temps pendant les différents changements lors des mesures.
Un reboot et c'est bon...

Suis le seul à avoir ces soucis?
Merci A++

pacapona
Messages : 11
Enregistré le : jeu. 10 nov. 2016 18:10

Re: global10k2x3 instabilité

Messagepar pacapona » mar. 15 nov. 2016 02:52

Oui Thierry je sais que ce que j'ai mis dans EQ_Globale ne fait rien... C'était justement le but, pour montrer le problème.
J'étais partis avec l'appli globale originale, sans FIR d'importer.
J'ai fait mes modif en IIR puis en ajoutant un truc dans EQ_Globale ça m'a tout péter alors que je n'avais pas lié de fichier exporter par rephase...

Les print screen ont été faits après coup en reprenant une sauvegarde et refaisant la manip.

En gros j'ai une appli qui n'a jamais eu d'import de FIR, dès que je touche a Globale_EQ il applique (plutot enlève d'après mois) des données FIR.

Donc pour repartir propre j'ais créer un export via rephase mais avec Zéro correction et j'importe ce fichier avant mes modifs, comme ça je part propre et c'est ok.

Si jamais j'ai encore la sauvegarde qui montre le bug, il suffit d'importer un fichier créer par rephase mais sans aucune modif et il change complétement le résultat.
Ce qui me fait penser que dans l'appli de base il y a déjà des correction FIIR ou sinon le dspiy garde en mémoire un ancien fichier même avec une nouvelle appli et nouveau preset.

J'espère que je suis compréhensible....

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 2793
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: global10k2x3 instabilité

Messagepar thierryvalk » mar. 15 nov. 2016 08:58

Hum...reprenons.

Instabilité est un mot trouvé par les informaticien pour dire que plus rien ne va mais l'on ne sait pas pourquoi.
Problème hardware, software ou utilisation ?
Relancer et refaire la même chose à l'identique n'est pas une méthode rationnelle.

Vu des coupure en Toslink, USB et autres problèmes de flash, il serait bon de revoir son câblage et hardware.
Je l'ai dit, l'alimentation par exemple. Avec l'ADAU1452 le courant peut monter brusquement et cela selon l'activité du DSP, si l'alim ne suit pas on peut avoir n'importe quoi.
Sur un DSPiy, on a parfois beaucoup de choses de branchés dont certains à la terre et donnant un chemin à certains courants indésirables via des câbles...

Ensuite la partie soft, faire un peu n'importe quoi sans trop de logique est une bonne méthode pour le tester et le faire planter. :0

Je ne comprend pas le pourquoi d'un preset sans Impulse, voici ce que donne la courbe sans avoir fait d'import de SA propre Impulse :
paca.png

Sans aucun intérêt, en toute logique l'utilisateur va créer une première Impulse sans aucune correction; cela lui permettant de vérifier s'il a bien configuré rePhase.
Ensuite il la charge, fait ses mesures, fait ses corrections, les importes et au final va créer un Preset lorsqu'il a une solution qui tient la route.

A noter que l'USB peut planter le système, c'est très rare mais possible.
Ce n'est pas un bug ni instabilité, juste un mécanisme de protection.
L'USB peut foirer : parasite, timing ... pour bien faire, le DSPiy devrait en avertir DStudio qui renverrait le dernier paquet et l'on n'y verrait rien.
Mais voila, c'est pas simple à faire et encore moins à tester car ce genre de mécanisme peut très bien boucler créant un blocage complet du PC.

pacapona
Messages : 11
Enregistré le : jeu. 10 nov. 2016 18:10

Re: global10k2x3 instabilité

Messagepar pacapona » mar. 15 nov. 2016 09:42

Merci pour ta réponse thierry mais elle me déprime quand même un peu.
J'ai beau me relire je ne comprend pas que mon message sois aussi incompréhensible, mais oui peut-être un peu long et barbant a lire.

J’abandonne l'idée d'expliquer l'histoire du globale_eq à zéro
Pour la config et mesure j’utilise la même depuis que j'ai du multidspiy en v1, sans aucun problème. Seul différence la partie import de FIIR...

Mon alime est une Teradak 5v 30W, complètement overkill j'imagine.

Reste l'usb, effectivement j'utilise une rallonge avec répétiteur de signale.
Je vais changer ma position lors des mesures afin d'être + proche du dspiy.

Oui le titre et mal choisi...
Tous ces problèmes ne viennent sûrement que de moi.

Avatar de l’utilisateur
thierryvalk
Administrateur du site
Messages : 2793
Enregistré le : jeu. 9 juil. 2015 20:08
Localisation : Belgique

Re: global10k2x3 instabilité

Messagepar thierryvalk » mar. 15 nov. 2016 11:16

Oui Thierry je sais que ce que j'ai mis dans EQ_Globale ne fait rien... C'était justement le but, pour montrer le problème.
J'étais partis avec l'appli globale originale, sans FIR d'importer.

Cette appli utilise le second DSP pour faire du FIR qui est basé sur une Impulse, donc il y a obligatoirement une Impulse et celle dans l'appli nous fait un petit creux à 1kHz.
Ce que l'on voit bien sur ta courbe.

Du coup rebelotte nettoyage mais cette fois que le preset avec import du travail de rephase. ok j'ai du son.
J'ai ajouter le preset sans rephase en 2 + reboot, cette fois je peux switcher de l'un a l'autre sans soucis... pas compris...
Là aussi, il faudrait voir pour partir de quelque chose de logique et le plus simple serait de n'avoir qu'un seul Preset pour commencer.
Et surtout ne pas mettre de Preset dont on ne sait pas comment ils sont faits ou tout simplement incomplets.


Retourner vers « DSPiy général »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité